Author Topic: Sparky APTus cannot be opened  (Read 2199 times)

Offline Goofy

  • Newbie
  • *
  • Posts: 36
Sparky APTus cannot be opened
« on: January 01, 2017, 05:46:52 pm »
Hello members,

I have made a new installation of Sparky Game over. As I wanted to use the Aptus-tool, I noted, that it cannot be opened.

1. I start the Aptus-link from the Menu
2. It appears the window for the login as the Administrator.
3. I fill up the password and push the ok-button
4. nothing happens...!

What is wrong?


Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1678
    • SparkyLinux
Re: Sparky APTus cannot be opened
« Reply #1 on: January 01, 2017, 09:10:10 pm »
Did you make a system upgrade?
If yes, make sure you have 'lxpolkit' package installed.

Run it via a terminal emulator and check the output:
Code: [Select]
remsu sparky-aptusor
Code: [Select]
sudo aprky-aptus
Nothing is easy as it looks.
Danielle Steel

Offline Goofy

  • Newbie
  • *
  • Posts: 36
Re: Sparky APTus cannot be opened
« Reply #2 on: January 02, 2017, 01:17:18 pm »
Hello pavroo,
thank you for the fast reply.

I thought, I would have done a system upgrade with running the programm "Sparky first run". But it seems so, that it has not functioned.

The 'lxpolkit'-package? Unfortunately I don't know, how I can check this... (I'm a poor MS-Windows-rat)    :-\
in the Menu of  the Sparky-Desktop I could not discover it...
So I have ignored this point.

I opened the LXTerminal:

The command       "remsu sparky-aptus"
had no reaction.

The command         "sudo sparky-aptus"
had started the APTus-Programm.        :)

Here I could create an update-list and then run a system-update. The programm downloaded 574MB! and it seemed that the update-process was running.
After this was finished, I started the computer anew.
But unfortunately the problem is the same: I can't start the APTus from the Menu: It seems that it was opening a window in the background for a second, but in the end it doesn't appear a programm-window.
So I repeat the process with opening the LXTerminal and the command "sudo sparky-aptus". Now the programm doesn't create  a new update-list; I think because it's done by the first time and I conclude, that the system is now up to date.

At this moment where I write these sentences, I want start the APTus-Programm via opening the LXTerminal and the command "sudo sparky-aptus" again for a better explanation, but the system answers:
"yad: cannot create shared memory for key 123450: Die Datei existiert bereits"   ("Die Datei existiert bereits" = "the file already exists")
I think I must start the computer anew.

Offline blaze

  • Jr. Member
  • **
  • Posts: 92
  • blazing away
Re: Sparky APTus cannot be opened
« Reply #3 on: January 02, 2017, 01:43:55 pm »
Code: [Select]
apt-cache policy lxpolkit
Will give you the answer.
Unstable OpenBoxer

Offline Goofy

  • Newbie
  • *
  • Posts: 36
Re: Sparky APTus cannot be opened
« Reply #4 on: January 02, 2017, 02:06:28 pm »
Thank you, blaze,

the system answers:

lxpolkit:
  Installiert:           (keine)
  Installationskandidat: 0.5.3-1
  Versionstabelle:
     0.5.3-1 500
        500 http://ftp.debian.org/debian testing/main amd64 Packages

It seems, that lxpolkit is not installed...    :-\

How can I install lxpolkit? Can I use the APTus-Programm (which is only running with the Terminal-command)?

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1678
    • SparkyLinux
Re: Sparky APTus cannot be opened
« Reply #5 on: January 02, 2017, 02:45:48 pm »
Run in the LXterminal:
Code: [Select]
sudo apt update
sudo apt install lxpolkit
Then reboot to let the LXDE uses lxpolkit on startup.
Nothing is easy as it looks.
Danielle Steel

Offline Goofy

  • Newbie
  • *
  • Posts: 36
Re: Sparky APTus cannot be opened
« Reply #6 on: January 02, 2017, 02:50:53 pm »
Hehe, I'm a superman  ;D

with the command

sudo apt-get install lxpolkit

the lxpolkit is now installed.

If it helps to the problem, that APTus cannot be opened from the menu of the sparky-desktop, I will see later. probably I must restart the computer...

Offline Goofy

  • Newbie
  • *
  • Posts: 36
Re: Sparky APTus cannot be opened
« Reply #7 on: January 02, 2017, 02:53:36 pm »
Thank you, pavroo,

you wrote to the same time to me, as I wrote my post.

 :)

Offline Goofy

  • Newbie
  • *
  • Posts: 36
Re: Sparky APTus cannot be opened
« Reply #8 on: January 02, 2017, 04:24:22 pm »
Hello pavroo,

after installing lxpolkit and rboot the computer unfortunately the problem is the same: I can't start the APTus from the Menu.

It seems strange, that I am the first or the only one which has this problem? You would think that my computer is perhaps a kind of Millennium Falcon of Han Solo, but nothing!

With your help the problem is not essential now, because I can start APTus with the command, but it's not nice.

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1678
    • SparkyLinux
Re: Sparky APTus cannot be opened
« Reply #9 on: January 02, 2017, 06:32:13 pm »
Show me:
Code: [Select]
pidof lxpolkit
Code: [Select]
apt-cache policy lxpolkit
Code: [Select]
ls -l $HOME/.config/autostart
Code: [Select]
cat $HOME/.config/autostart/lxpolkit.desktop
What is your sparky installation? 32 or 64 bit?
« Last Edit: January 02, 2017, 06:38:44 pm by pavroo »
Nothing is easy as it looks.
Danielle Steel

Offline Goofy

  • Newbie
  • *
  • Posts: 36
Re: Sparky APTus cannot be opened
« Reply #10 on: January 03, 2017, 07:59:24 am »
Hello pavroo,

these are the answers from the system to "your" commands:

goofy@pc01goofy:~$ pidof lxpolkit
1448
goofy@pc01goofy:~$ apt-cache policy lxpolkit
lxpolkit:
  Installiert:           0.5.3-1
  Installationskandidat: 0.5.3-1
  Versionstabelle:
 *** 0.5.3-1 500
        500 http://ftp.debian.org/debian testing/main amd64 Packages
        100 /var/lib/dpkg/status
goofy@pc01goofy:~$ ls -l $HOME/.config/autostart
insgesamt 0
goofy@pc01goofy:~$ cat $HOME/.config/autostart/lxpolkit.desktop
cat: /home/goofy/.config/autostart/lxpolkit.desktop: Datei oder Verzeichnis nicht gefunden (file or directory not found)

I have installed the Sparky-64bit-version

Offline Goofy

  • Newbie
  • *
  • Posts: 36
Re: Sparky APTus cannot be opened
« Reply #11 on: January 03, 2017, 09:19:00 am »
Mayby some additional Informations with importance:

The Sparky-First-Run programm is also running only with the terminal-command. I tried the command:

sudo sparky-firstrun

Now, it has downloaded some files. In the end it showed the message:

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1678
    • SparkyLinux
Re: Sparky APTus cannot be opened
« Reply #12 on: January 03, 2017, 12:17:05 pm »
1. How did you install sparky - using live installer or advanced installer?
2. Did you change root password or you use only one for user 'goofy' and root?
3. show me:
Code: [Select]
groups
Code: [Select]
ls -l $HOME/.su-to-root4. What happens running:
Code: [Select]
gksu sparky-aptus
Code: [Select]
gksudo sparky-aptus
Nothing is easy as it looks.
Danielle Steel

Offline Goofy

  • Newbie
  • *
  • Posts: 36
Re: Sparky APTus cannot be opened
« Reply #13 on: January 03, 2017, 02:41:19 pm »
Hello pavroo,
first I want say that I'm very grateful to you for your help!   :)

1. Surely I have used the live installer. All the installation running automatically.
2. No, I haven't changed the root password.
    No, I think the user goofy and root are seperatly (I remember there was a question about this during the installation). But in the login-window it is only possibel to use the user goofy; It's no option to login as root.
3. (...Unfortunately I can't find an option to set the LXTerminal-window to english...)
Here are the results:

goofy@pc01goofy:~$ groups
goofy adm dialout fax cdrom floppy tape sudo audio dip video plugdev users fuse scanner lpadmin bluetooth netdev
goofy@pc01goofy:~$ ls -l $HOME/.su-to-root
ls: Zugriff auf '/home/goofy/.su-to-root' nicht möglich: Datei oder Verzeichnis nicht gefunden
(access to '/home/goofy/.su-to-root'  not possible: file or directory not found)

4.
goofy@pc01goofy:~$ gksu sparky-aptus
goofy@pc01goofy:~$ gksudo sparky-aptus
goofy@pc01goofy:~$

To the last both commands in point 4, the system doesn't give any answer.


Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1678
    • SparkyLinux
Re: Sparky APTus cannot be opened
« Reply #14 on: January 03, 2017, 02:59:50 pm »
Sorry, should be '.su-to-rootrc'
If it doesn't exist, run:
Code: [Select]
leafpad .su-to-rootrctype into the file:
Code: [Select]
SU_TO_ROOT_SU=sudosave the file, then re-login to your account.

Edit:
one more question, if the file exist, and still no luck, run and show the output:
Code: [Select]
gksu -d sparky-aptus
Code: [Select]
gksudo -d sparky-aptus
« Last Edit: January 03, 2017, 03:09:21 pm by pavroo »
Nothing is easy as it looks.
Danielle Steel