Advertising

Author Topic: Unable to mount usbstick since upgrade (gvfs?)  (Read 7722 times)

Offline piker

  • Jr. Member
  • **
  • Posts: 50
Re: Unable to mount usbstick since upgrade (gvfs?)
« Reply #15 on: December 06, 2016, 12:22:37 pm »
Heres mine, pavroo..

Model: ATA OCZ-VERTEX4 (scsi)
Disk /dev/sda: 128GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number  Start   End    Size    Type      File system     Flags
 1      1049kB  110GB  110GB   primary   ext4            boot
 2      110GB   128GB  17.8GB  extended
 5      110GB   128GB  17.8GB  logical   linux-swap(v1)


Model: ATA TOSHIBA MK3256GS (scsi)
Disk /dev/sdb: 320GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number  Start   End    Size   Type     File system  Flags
 1      1049kB  320GB  320GB  primary  ext4


Model: Verbatim STORE N GO (scsi)
Disk /dev/sdc: 15.5GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  15.5GB  15.5GB  primary  fat32        boot

# the STORE N GO is the USB flash drive

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2037
    • SparkyLinux
Re: Unable to mount usbstick since upgrade (gvfs?)
« Reply #16 on: December 06, 2016, 12:27:39 pm »
and how your /etc/fstab looks like?
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux at irc.freenode.net

Offline piker

  • Jr. Member
  • **
  • Posts: 50
Re: Unable to mount usbstick since upgrade (gvfs?)
« Reply #17 on: December 06, 2016, 12:31:56 pm »
I haven't put an entry for USB flash drives in there:

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc   /proc   proc   defaults   0   0
#Entry for /dev/sda1 :
UUID=3a6ecf5a-7c47-44d3-9718-e83b9c6e4aac   /   ext4   defaults,noatime,errors=remount-ro,discard   0   1
#Entry for /dev/sdb1 :
UUID=5fd5300d-3091-4c1c-b6e2-eaf5e5bd641f   /media/daryl/Backups   ext4   defaults,nosuid,nodev,relatime,data=ordered   0   0
#Entry for /dev/sda5 :
UUID=895b06c9-5b52-40b2-9673-58057030f53c   swap   swap   sw   0   0

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2037
    • SparkyLinux
Re: Unable to mount usbstick since upgrade (gvfs?)
« Reply #18 on: December 06, 2016, 12:39:34 pm »
Just a test - can you comment the line:
Code: [Select]
UUID=5fd5300d-3091-4c1c-b6e2-eaf5e5bd641f   /media/daryl/Backups   ext4   defaults,nosuid,nodev,relatime,data=ordered   0   0to be not mounted automatically and reboot to check.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux at irc.freenode.net

Offline piker

  • Jr. Member
  • **
  • Posts: 50
Re: Unable to mount usbstick since upgrade (gvfs?)
« Reply #19 on: December 06, 2016, 12:48:29 pm »
Ok, did that. I get a "Not authorized to perform operation" message for the Backups drive as well as the usb flash drive now.

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2037
    • SparkyLinux
Re: Unable to mount usbstick since upgrade (gvfs?)
« Reply #20 on: December 06, 2016, 12:56:13 pm »
what groups do you belong? run (as regular user):
Code: [Select]
groupsand what is your desktop you are using now?
« Last Edit: December 06, 2016, 12:59:21 pm by pavroo »
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux at irc.freenode.net

Offline piker

  • Jr. Member
  • **
  • Posts: 50
Re: Unable to mount usbstick since upgrade (gvfs?)
« Reply #21 on: December 06, 2016, 12:58:34 pm »
daryl@lapdog:~$ groups
daryl adm dialout fax cdrom floppy tape sudo audio dip video plugdev users scanner lpadmin netdev bluetooth fuse

#I am using lxqt desktop
« Last Edit: December 06, 2016, 01:02:07 pm by piker »

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2037
    • SparkyLinux
Re: Unable to mount usbstick since upgrade (gvfs?)
« Reply #22 on: December 06, 2016, 01:12:31 pm »
I have to upgrade my lxqt installation now, but ...
Did the mounting work before upgrading, right?
Did you upgrade the kernel too then?
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux at irc.freenode.net

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2037
    • SparkyLinux
Re: Unable to mount usbstick since upgrade (gvfs?)
« Reply #23 on: December 06, 2016, 01:32:15 pm »
To have privileges in lxqt desktop, there is 'lxqt-policykit' required, so check is it installed.
Check does it work now, too:
Code: [Select]
pidof lxqt-policykit-agent
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux at irc.freenode.net

Offline piker

  • Jr. Member
  • **
  • Posts: 50
Re: Unable to mount usbstick since upgrade (gvfs?)
« Reply #24 on: December 06, 2016, 09:07:49 pm »
pavroo.
I just did the "System Upgrade" as normally, via the menu icon. I am now running kernel 4.8.0-1-amd64.
Yes, mounting USB flash drives worked just fine before upgrading.
"pidof lxqt-policykit-agent" returns 1522, so it seems to be installed and working.

Offline piker

  • Jr. Member
  • **
  • Posts: 50
Re: Unable to mount usbstick since upgrade (gvfs?)
« Reply #25 on: December 06, 2016, 09:48:41 pm »
Possibly found something here:
LXQt session settings -> Autostart
LXPolKit has an exclamation mark and when i hover over it says " Location: /home/daryl/.config/autostart/lxpolkit.desktop    Overrides: /etc/xdg/autostart/lxpolkit.desktop"
# anything in this?

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2037
    • SparkyLinux
Re: Unable to mount usbstick since upgrade (gvfs?)
« Reply #26 on: December 06, 2016, 11:12:27 pm »
aaaahhhhh!
How did you install lxqt? via minimalGUI/CLI iso? Let me know, please.

LXQt does not use lxpolkit, your existing lxpolkit.desktop brakes the default one so remove:
Code: [Select]
/home/daryl/.config/autostart/lxpolkit.desktopLXQt uses lxqt-policykit-agent instead.

Then reboot.
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux at irc.freenode.net

Offline piker

  • Jr. Member
  • **
  • Posts: 50
Re: Unable to mount usbstick since upgrade (gvfs?)
« Reply #27 on: December 07, 2016, 01:21:42 am »
I uninstalled lxsession (should I have purged as well?), then found that lxqt-policykit was already installed anyway, rebooted, inserted a usb flash disk and still got the "Not authorized ..." error. However when I clicked on the Removeable media/devices Manager (menu bar)->USBDISK and it opened another session of PcmanFm in which it was actually accessible! (If I already had a PCManFm session running the USBDISK is not accessible).There is still some kind of Permissions problem here somewhere and i'm willing to keep at this if you want to get to the bottom of it completely pavroo, but I do have a useable USB Disk now.
#almost forgot to mention that this was purely a System Upgrade and not a full installation. I've been a happy user of SparkyLinux LXQt for almost a year without issues.
« Last Edit: December 07, 2016, 01:23:57 am by piker »

Offline red.iceman

  • Newbie
  • *
  • Posts: 9
Re: Unable to mount usbstick since upgrade (gvfs?)
« Reply #28 on: December 08, 2016, 10:01:29 pm »
Quote
I just did the "System Upgrade" as normally. I am now running kernel 4.8.0-1-amd64.
Yes, mounting USB flash drives worked just fine before upgrading.
The same is true for me. Unlike Piper, I use budgie-desktop und xfce. Thus neither lxsession nor lxqt-polkit are installed. Everything works fine as long as I do not use a display manager. Have you ever tried that, Piper?

Offline pavroo

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2037
    • SparkyLinux
Re: Unable to mount usbstick since upgrade (gvfs?)
« Reply #29 on: December 09, 2016, 03:33:45 pm »
The budgie desktop uses its own polkit front-end called 'budgie-polkit'.
Check does it work when the Budgie is loaded:
Code: [Select]
pidof budgie-polkit-dialog
The Xfce uses 'polkit-gnome-authentication-agent-1', so make sure is loaded with the Xfce ddesktop:
Code: [Select]
pidof polkit-gnome-authentication-agent-1
According to similar issue with LXQt desktop, check what files exist in your home autostart dir:
Code: [Select]
~HOME/.config/autostart/
Nothing is easy as it looks. Danielle Steel
Join #sparkylinux at irc.freenode.net