Author Topic: How to submit bugs?  (Read 680 times)

Offline kulturedyobbo

  • Newbie
  • *
  • Posts: 12
  • Linux user 1999. PHP/MySQL http://barwinski.net
How to submit bugs?
« on: July 29, 2016, 12:17:17 pm »
This may sound lie a stupid question, but how do you submit a bug? Whenever I follow the links for it, I find the bug "ticket" button greyed out. I have already created a Sourceforge account. Right now I want to submit a bug report for Libreoffice 5.1.5~rc1-1 with it slow scrolling speed making it unusable for even documents of moderate complexity like only 50 pages.

Cheers

Offline paxmark1

  • Full Member
  • ***
  • Posts: 209
Re: How to submit bugs?
« Reply #1 on: July 30, 2016, 05:35:02 am »
Bug reporting depends on where you want to send the necessary information.    Since most of the packages involved are going to be Debian packages, you might want to report the bugs to Debian.  The package maintainers can and often do push information upstream to the generators of the source code.  A start would be to read

https://www.debian.org/Bugs/Reporting

Of course, before starting a new bug, search the "BTS" or bug tracking service.

https://www.debian.org/Bugs/

For looking closer, try

https://bugs.debian.org/cgi-bin/pkgreport.cgi?dist=unstable;package=libreoffice

and if it happens in writer

https://bugs.debian.org/cgi-bin/pkgreport.cgi?package=libreoffice-writer

peace out

Don't make a FrankenDebian

Offline kulturedyobbo

  • Newbie
  • *
  • Posts: 12
  • Linux user 1999. PHP/MySQL http://barwinski.net
Re: How to submit bugs?
« Reply #2 on: August 05, 2016, 01:25:17 pm »
Thanks for your reply.

That is in fact what I did initially, but I found that the Debian maintainers were not happy with me submitting bugs for a non-Debian OS, even though I pointed out that Sparky was fully compatible with and based on Debian testing Stretch. In this case, with the dodgy Libreoffice 5.1.5~rc1-1, I ended up submitting the bug on bugzilla straight to Libreoffice. I noticed today (Friday 05th August 2016) when I did my system update, that Libreoffice was upraded to 5.1.5~rc2-1, but the bug is still there. Thus, I ended up purging my system of Libreoffice, and downgrading to 5.1.4.2-2, which works perfectly.