Advertising

Author Topic: Is there a way to kill the log out sound when logging out of SparkyLinux Xfce?  (Read 1750 times)

Offline perknh

  • Jr. Member
  • **
  • Posts: 61
  • Soy un huevo, nada más.
Hello SparkyLinux Forum,

Is there a way to kill the log out sound, or beep, when logging out of SparkyLinux Xfce?  I can't find where that sound is located in Sparky's Xfce so I can turn it off.

Thank you,

perknh

P.S.

Sorry, although this is a newbie question, I now believe this question belongs more in the Desktops topic area instead of Newbie Questions.  I don't know how to move it there, and I don't wont to double post.  I'm sorry about this. :-[
« Last Edit: October 18, 2015, 02:28:11 pm by perknh »

Offline michael-hi

  • Newbie
  • *
  • Posts: 2
I realise this is a fairly old post but, as no-one else has answered the question, this reply may be helpful to someone. I have just had the same problem when installing SparkyLinux 4.3 (XFCE, 32 bit version) for the first time in order to try it out. There is an annoying loud beep when clicking the logout button (and also, for example, when you accidentally try and backspace past the beginning of a document or text field). After googling, I found that this command disables the beep:
Code: [Select]
xset -bTry entering the above in a terminal and then there should be no beep  when you log out or shut down. If it works, then you can make the command work automatically each time you log in to XFCE by including it in Autostart. Under Settings in the main XFCE Menu, choose "Session and Startup", then click on the "Application Autostart" tab. Click "Add" and three text boxes appear. Put whatever you like for Name and Description, eg Beep Off and Mutes beep, then type the above command in the third box, click OK and that should solve it.

It would perhaps be better if this annoying beep was disabled by default in Sparky but maybe it is in the other versions - I haven't  actually tried them.

Offline perknh

  • Jr. Member
  • **
  • Posts: 61
  • Soy un huevo, nada más.
Thank you, michael-hi.  Sorry for taking so long to thank you for this.  Until today, I hadn't known anyone had responded to that question. :-[

Offline lami07

  • Global Moderator
  • Newbie
  • *****
  • Posts: 49
    • Sparky Community Repos
There are more ways to disable/blacklist internal speaker (beep).
You can read about some of them here:
Code: [Select]
https://www.linuxquestions.org/questions/debian-26/disable-the-pc-speaker-beep-913444/
Code: [Select]
https://wiki.archlinux.org/index.php/PC_speaker#Disable_PC_Speaker
Quote from: forum rules
When an issue has been resolved for you, please edit the original post to include <SOLVED> in the title. This provides a good indicator for users with a similar problem to check out the thread
Want to chat? Join #sparkylinux at irc.freenode.net