Author Topic: Update 2015-09-06  (Read 920 times)

Offline hallenberger

  • Newbie
  • *
  • Posts: 8
Update 2015-09-06
« on: September 06, 2015, 06:52:40 pm »
I have made a dist-upgrad today and many files were removed/updated.

vlc, gimp, flamerobbin, inkscape for example are removed.

If I made another "sudo apt-get dist-upgrade" the result is:

Code: [Select]
The following packages have been kept back:
gparted gstreamer1.0-plugins-good nitrogen ripperx

If I try

Code: [Select]
sudo apt-get install vlc

I get:

Code: [Select]
The following packages have unmet dependencies:
vlc: Depends: be installed but should not: vlc-nox (2.2.1-dmo10 = 1)
        Recommends: VLC plugin-notify (= 1: 2.2.1-dmo10) but should not be installed
E: problems can not be corrected, you have retained broken packages.

Also with the other programs.

What can I do?


Offline paxmark1

  • Full Member
  • ***
  • Posts: 175
Re: Update 2015-09-06
« Reply #1 on: September 06, 2015, 08:25:24 pm »
1.. what version of sparky do you have?

2.  When the dist-upgrade  states that large changes, especially when programs  are to be removed, it is wise to answer "n" and investigate. 

3.  Waiting at this point is your best bet.  nitrogen, gparted and vlc all are being held back by the gcc++6 transition

4.. lurk at OFTC irc at #debian-next  others will be having similar problems.

5.  Read the threads at  and

learning more about "apt-cache showpkg foo"       "sudo apt-get -s upgrade" (-s is --simulate   - a dry run)   also "sudo apt-get -s dist-upgrade -d | less"
Don't make a FrankenDebian

Offline hallenberger

  • Newbie
  • *
  • Posts: 8
Re: Update 2015-09-06
« Reply #2 on: September 07, 2015, 04:30:55 am »
Thank you for your tips.

The next time I will remember your tips.