Advertising

Author Topic: [Solved] Plymouth boot screen to quit.  (Read 7817 times)

Offline way12go

  • Sr. Member
  • ****
  • Posts: 479
  • Life is a unique pattern.
[Solved] Plymouth boot screen to quit.
« on: August 13, 2014, 05:50:58 am »
I get "Plymouth boot screen to quit" during shutdown and restart and it takes a minute or two. Is this normal.

I found the solution...

Quote
First of all, I see that plymouth-quit-wait.service is still runing during boot,
Quote
so please execute (as root)
:
Quote
systemctl mask plymouth-quit-wait.service (this will disable this service).

More to that, according to your question do (all commands as root):

    If you don't need dynamic firewall:
Quote
systemctl disable firewalld.service
    If you don't use lvm (check this by (as root) lvs, and post result here):
Quote
systemctl disable lvm2-monitor.service
and
Quote
systemctl disable lvm2-lvmetad.service
Quote
    systemctl disable avahi-daemon.service
Quote
    systemctl disable dmraid-activation.service
Quote
    systemctl disable livesys-late.service
Quote
    systemctl disable livesys.service
Quote
    systemctl disable sendmail.service
Quote
    systemctl disable sm-client.service
    If you don't need to connect (as a cient) to NFS server or NIS server, then disable:
Quote
systemctl disable rpcbind.service
    If you don't need Bluetooth:
Quote
systemctl disable bluetooth.service
    If you don't need time synchronization:
Quote
systemctl disable chronyd.service
    If you don't need Plymouth (this graphic-animation boot)
Quote
systemctl disable plymouth-read-write.service
and
Quote
systemctl disable plymouth-start.service

Quote
If for some reasons, after reboot you still see any of disabled by you service in systemd-analyze blame, then redo command, but replace disable with mask, eg: systemctl disable rpcbind.service doesn't work, rpcbind is still running, then: systemctl mask rpcbind.service.
Again, all command execute as root (or at least by sudo).

After you done, and none of this service is running again, update your question with results from; systemd-analyze; systemd-analyze blame
« Last Edit: August 15, 2014, 08:48:27 am by way12go »
Life is a unique pattern.

Offline way12go

  • Sr. Member
  • ****
  • Posts: 479
  • Life is a unique pattern.
Re: [Solved] Plymouth boot screen to quit.
« Reply #1 on: August 15, 2014, 09:14:46 am »
 Debian Wheezy boot splash screens
Grub wallpaper and resolution can be changed by editing
  /etc/default/grub
and running:
 update-grub

The boot splash screen can be enabled by editing
  /etc/default/grub
and adding "splash" to the Grub command line:
  GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
and running:
  update-grub

The splash will not appear unless a splash package is installed.
The only package available in standard repositories is plymouth:
  apt-get install plymouth-x11

Other external packages:
 Bootsplash - original kernel space implementation
 Usplash - designed to replace Bootsplash, implemented in User space
 Xsplash - used in Ubuntu Karmic to take over from Usplash
 Plymouth - designed to replace Usplash+Xsplash
 Splashy - a Debian project, last updated in 2008, implements splash using framebuffers in user space, not  compatible with startup system in Wheezy.
 Fbsplash - a Gentoo splash implementation, not available for Debian


Once installed, the plymouth splash theme is updated using:
  plymouth-set-default-theme

*When plymouth is removed, it still leaves the theme embedded in initrd.  To complete the removal of plymouth boot splash, update the initrd image:
  update-initramfs

**Wheezy contains a package called "startupmanager" which is described as providing an easy to use interface to update some settings for grub & splash screens - but it does not give correct resolutions and only  has a tick-box to enable or disable splash screen.  startupmanager corrupts /etc/grub.d/00_header by hard-coding a resolution that will prevent GRUB_GFXMODE from working in /etc/default/grub.

***Screen corruption occurs if using Slim display manager when Plymouth is installed.
Life is a unique pattern.